Cisco交換機經常使用配置命令總結

1:配置VLAN                                                          
        理解VLAN : 一個VLAN就是一個交換網,其邏輯上按功能、項目、應用來分而沒必要考慮用戶的物理位置。任何交換口均可以屬於某一VLAN, IP包、廣播包及組播包都可以發送或廣播給在此VLAN內的最終用戶。每個VLAN都可當作是一個邏輯網絡,發往另外一VLAN的數據包必須由路由器或網橋轉發,因爲VLAN被當作是一個邏輯網絡,其具備本身的網橋管理信息庫 (MIB) 並可支持本身的生成樹
在Cisco交換機裏面有兩種配置Vlan的方法:
Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
也能夠在enable狀態下,進行VLAN配置:
Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
當刪除一個處於VTP服務器的交換機上刪除VLAN時,則此VLAN將在全部相同VTP的交換機上刪除。當在透明模式下刪除時,只在當前交換機上刪除, vlan database 進入VLAN配置狀態,用no vlan vlan-id 來刪除。
Switch# vlan database
Switch(vlan)# no vlan 20
Switch(vlan)# exit
Switch# configure terminal
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end                                                                              
所謂的TRUNK是用來在不一樣的交換機之間進行鏈接,以保證在跨越多個交換機上創建的同一個VLAN的成員可以相互通信,若是是不一樣臺的交換機上相同id的vlan要相互通訊,那麼能夠經過共享的trunk端口就能夠實現,若是是不一樣臺不一樣id的vlan它們之間要相互通訊,須要經過第三方的路由來實現.
Switch# configure terminal
Switch(config)# interface fastetherne2/4
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end
定義trunk容許的VLAN
缺省狀況下trunk容許全部的VLAN經過,可使用 switchport trunk allowed vlan remove vlan-list 來去掉某一VLAN
Switch(config)# interface fastethernet2/4
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end                                                                              
負載均衡可使用流量分流到其它平行的trunks上去. 交換機爲了不環路,STP一般是阻斷全部端×××換機之間只留一條鏈路,使用負載均衡後, 能夠把不一樣VLAN的流量分配到不一樣的trunk上。
能夠經過配置STP端口權值STP路徑值來實現負載均衡,若是使用STP端口權值來配置那麼二條負載均衡的trunk必須聯同一交換機上;使用路徑值則便可以聯相同的交換機與能夠聯不一樣的交換機。

使用STP端口權值的負載均衡服務器

當同一臺交換機的二個口造成環路時, STP端口權值用來決定那個口是enable的,那個口是阻斷的。 能夠經過配置端口權值來決定二對trunk各走那些VLAN, 有較高權值的端口(數字較小的)vlan, 將處於轉發狀態,同一個VLAN在另外一個trunk有較低的權值(數字較大)則將處在阻斷狀態,即同一VLAN只在一個trunk上發送接受。
基於端口權值的負載均衡,trunk1將發送和接收VLAN8-10的數據,trunk2將發送和接收VLAN3-5的數據
interface fastethernet0/1  (進入Trunk1口)
spanning-tree vlan 8 port-priority 10
spanning-tree vlan 9 port-priority 10
spanning-tree vlan 10 port-priority 10
interface fastethernet0/2  (進入Trunk2口)
spanning-tree vlan 3 port-priority 10
spanning-tree vlan 4 port-priority 10
spanning-tree vlan 5 port-priority 10
也能夠經過配置配置STP路徑值來實現負載均衡,Trunk1走VLAN8-10,Trunk2走VLAN2-4
interface fastethernet 0/1 (進入Trunk1口)
spanning-tree vlan 8 cost 30
spanning-tree vlan 9 cost 30
spanning-tree vlan 10 cost 30
interface fastethernet 0/2 (進入Trunk2口)
spanning-tree vlan 2 cost 30
spanning-tree vlan 3 cost 30
spanning-tree vlan 4 cost 30

4:配置EtherChannel網絡

etherchannel特性在switch到switch、switch到router之間提供冗餘的、高速的鏈接方式,簡單說就是將兩個設備間多條 fe或ge物理鏈路捆在一塊兒組成一條設備間邏輯鏈路,從而達到增長帶寬,提供冗餘的目的, 每一個以太通道具備一個port-channel端口號,要捆綁一個以太通道時,會產生一個邏輯port-channel端口,邏輯端口下的配置可影響與之捆綁的物理端口,但物理端口下的配置不能影響邏輯端口的配置
Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# ip address 172.16.30.10 255.255.255.0
Switch(config-if)# end
Switch# configure terminal
Switch(config)# interface range fastethernet 3/4 - 5
Switch(config-if)# no switchport
Switch(config-if)# no ip address
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# end

二層以太通道配置負載均衡

Switch# configure terminal
Switch(config)# interface range fastethernet 2/6 - 7
Switch(config-if-range)# channel-group 2 mode desirable
Switch(config-if-range)# end

5:配置以太通道負載均衡ide

負載均衡關鍵字表示以下:
src-mac—源MAC地址
dst-mac—目標MAC地址
src-dst-mac—源和目標MAC地址
src-ip—源IP地址
dst-ip—目標IP地址
src-dst-ip—源和目標IP地址 (缺省)
src-port—源第四層端口
dst-port—目標第四層端口
src-dst-port—源和目標第四層端口
Switch(config)# port-channel load-balance src-dst-ip
Switch(config)# end
This example shows how to verify the configuration:
Switch# show etherchannel load-balance
Source XOR Destination IP address
Switch#
相關文章
相關標籤/搜索