POJ 2234 Matches Game

Matches Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7567   Accepted: 4327

Descriptionios

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Inputthis

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Outputspa

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Inputcode

2 45 45
3 3 6 9

Sample Outputblog

No
Yes
題目大意:有N堆石子,每堆M個,每次能夠從任意一堆中取走任意個石子,問先手可否獲勝。
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

int main()
{
    int ans, n, pile[30];
    while(scanf("%d", &n) != EOF)
    {
        ans = 0;
        memset(pile, 0, sizeof(pile));
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &pile[i]);
            ans ^= pile[i];
        }
        if (ans == 0)
        {
            printf("No\n");
        }
        else
        {
            printf("Yes\n");
        }
    }
    return 0;
}
相關文章
相關標籤/搜索