Sightseeing trip
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 9078 |
|
Accepted: 3380 |
|
Special Judge |
Descriptionios
There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.
In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.
Input算法
The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).
Outputless
There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.
Sample Inputide
5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20
Sample Outputthis
1 3 5 2
Sourcespa
題目大意:給定圖的N個點M條邊,求出圖中的最小環(無向圖,有重邊)。
解題思路:
int maxn=105;
int a[maxn][maxn],f[maxn][maxn];
a:鄰接矩陣,存圖
利用floyd算法;
f:記錄任意兩點間的最短距離,初值爲a.
f
(k)[i][j]表示從頂點i到頂點j,中間頂點序號不大於k的最短路徑長度。
f
(k)[i][j]=min(f
(k-1)[i][j],f
(k-1)[i][k]+f
(k-1)[k][j])
則最小環能夠表示爲a[i][k]+a[k][j]+f
(k-1)[i][j]
即表示從頂點i到頂點j,中間頂點序號不大於k-1的最短路徑長度+i到k的邊長+k到j的邊長。(這樣保證構成環,而沒有重邊)
#include<iostream>
#include<cstring>
using namespace std;
int n,m,ans=0x3f3f3f3f,s,t,temk=0x3f3f3f3f,cnt;
const int maxn=1000;
int a[maxn][maxn],d[maxn][maxn],f[maxn][maxn],path[maxn];
void dfs(int i,int j){
if(f[i][j]==0){path[++cnt]=j;return;}
dfs(f[i][j],j);
}
void floy(){
memset(path,0,sizeof(path));
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
d[i][j]=a[i][j];
for(int k=1;k<=n;k++){
for(int i=1;i<k;i++)
for(int j=i+1;j<k;j++)
if((long long)a[i][k]+a[k][j]+d[i][j]<ans){//注意數據類型,3個連加,容易超Int
ans=a[i][k]+a[k][j]+d[i][j];
s=i;t=j;
temk=k;
cnt=0;
path[++cnt]=s;
dfs(s,t);//記錄從s到t的中間節點,包含t,不含s.
path[++cnt]=k;
}
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(d[i][j]>d[i][k]+d[k][j]){
d[i][j]=d[i][k]+d[k][j];
f[i][j]=k;
}
}
return ;
}
int main(){
memset(a,0x3f,sizeof(a));
memset(f,0,sizeof(f));
cin>>n>>m;
for(int i=1;i<=n;i++) a[i][i]=0;
for(int i=1;i<=m;i++){
int x,y,w;
cin>>x>>y>>w;
if(w<a[x][y]){
a[x][y]=a[y][x]=w;
}
}
floy();
if(temk==0x3f3f3f3f)cout<<"No solution."<<endl;
else {for(int i=1;i<=cnt;i++) cout<<path[i]<<' ';cout<<endl;}
return 0;
}