POJ1056 IMMEDIATE DECODABILITY【數據結構】

題目地址:http://poj.org/problem?id=1056
this


Description編碼

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Inputcode

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Outputip

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Inputci

01
10
0010
0000
9
01
10
010
0000
9

Sample Outputget

Set 1 is immediately decodable
Set 2 is not immediately decodable
 

Sourceinput

Pacific Northwest 1998

將各個編碼序列做爲二叉樹的節點序列創建二叉樹,並在過程當中標記編碼序列的最後一位,而後遍歷二叉樹,若是存在非葉節點的istail爲1,便可說明存在某序列爲另外一序列的前綴序列。

#include <stdio.h>
#include <stdlib.h>

typedef struct btree{
	int istail;
	struct btree * left;
	struct btree * right;
}BTree, *pBTree;

char data[11];
BTree * root = NULL;

void insert(char data[]){
	int i= 0;
	BTree * p = NULL;
	if (root == NULL){
		root = (BTree *)malloc(sizeof(BTree));
		root->istail = 0;
		root->left = root->right = NULL;
	}
	p = root;
	while (data[i] != '\0'){
		if (data[i] == '0'){
			if (p->left != NULL){
				p = p->left;
			} else{
				p->left = (BTree *)malloc(sizeof(BTree));
				p = p->left;
				p->istail = 0;
				p->left = p->right = NULL;
			}
		} else{
			if (p->right != NULL){
				p = p->right;
			} else {
				p->right = (BTree *)malloc(sizeof(BTree));
				p = p->right;
				p->istail = 0;
				p->left = p->right = NULL;
			}
		}
		++i;
	}
	p->istail = 1;
}

int isImmediately(BTree * root){
	BTree * p = root;
	while (p != NULL){
		if (p->istail == 1 && (p->left != NULL || p->right != NULL))
			return 0;
		else
			return isImmediately(p->left) && isImmediately(p->right);
	}
	return 1;
}

void destoryBTree(pBTree * root){
		if ((*root)->left)
			destoryBTree(&(*root)->left);
		if ((*root)->right)
			destoryBTree(&(*root)->right);
		free(*root);
		*root = NULL;
}

int main(void){
	int count = 0;
	while (gets(data)){
		if (data[0] == '9'){	
			if (isImmediately(root))
				printf("Set %d is immediately decodable\n", ++count);
			else
				printf("Set %d is not immediately decodable\n", ++count);
			destoryBTree(&root);
		} else{
			insert(data);
		}
	}

	return 0;
}
相關文章
相關標籤/搜索