PAT 甲級 1042.Shuffling Machine C++/Java

題目來源html

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.ios

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:數組

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2 
 

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.dom

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (K≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.ide

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.spa

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5


題目大意:

第一行輸入:給定一個正整數K(K <= 20):洗牌的次數code

第二行輸入:洗牌的序列orm

 

有一副牌,從1 到 54 的順序是 S1...S13,H1...H13,C1...C13,D1...D13,J1,J2htm

給定一個洗牌序列 arrblog

 

好比

洗牌順序{4,2,5,3,1}
5張卡片: S3,H5,C1,D13,J2

S3  對應 4,S3   放在第 4 個位置
H5  對應 2,H5   放在第 2 個位置
C1  對應 5,C1   放在第 5 個位置
D13對應 3,C13 放在第 3 個位置
J2   對應 1,J2    放在第 1 個位置

獲得新的卡片:J2 H5 D13 S3 C1

 

輸出:洗牌K次後的序列,結尾不能有空格

 

分析:

我構造了一個字符串數組 orderCard[55] ,裏面包含了54張牌

將輸入的洗牌順序保存到vector數組

假定洗牌n次,就循環n次

每一次循環,都用一個臨時的字符串數組 temp[55] 保存洗牌後的順序,而後更新 orderCard 

每次循環,執行 temp[arr[i]] = orderCard[i]; 

最後將  temp 複製到 orderCard 

 

C++實現:

#include <iostream>
#include <vector>
#include <string>

using namespace std;

int main() {
    const int cardCount = 55;
    // orderCare[1-54] 表明着54張卡的編號
    string orderCard[cardCount] = { "0", "S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13",
                        "H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13",
                        "C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13",
                        "D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13",
                         "J1","J2" };
    int N;
    cin >> N;
    vector<int> arr(cardCount);
    for (int i = 1; i < cardCount; ++i) {
        cin >> arr[i];
    }

    for (int i = 0; i < N; ++i) {
        string temp[cardCount];
        for (int i = 1; i < cardCount; ++i) {
            temp[arr[i]] = orderCard[i];
        }
        
        for (int i = 0; i < cardCount; ++i) {
            orderCard[i] = temp[i];
        }
    }

    for (int i = 1; i < cardCount; ++i) {
        if (i != 1) {
            cout << ' ';
        }
        cout << orderCard[i];
    }
    return 0;
}

 

 

 

Java實現:

相關文章
相關標籤/搜索