UVA OJ-11095 Maximum Product(暴力求解法)

 

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.ios

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that -10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).ide

Output

For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.spa

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.
題目大意:最大連續子序列乘積
#include<iostream>
using namespace std;
int main() {
  int n, a[20], count = 1;
  while (cin >> n) {
    for (int i = 0; i < n; i++)
      cin >> a[i];
    long long max = 0;//若是最大乘積不是正數,輸出0 
    for (int i = 0; i < n; i++) {//枚舉起點 
      long long sum = 1;
      for (int j = i; j < n; j++) {//枚舉終點 
        sum *= a[j];
        if (sum > max)
          max = sum;
      } 
    }  
    cout << "Case #" << count++ << ": The maximum product is " << max << "." << endl;
    cout << endl;
  }
} 
相關文章
相關標籤/搜索