Description
Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.
Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Input
The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.
The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
Output
Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4 1 1 2 3 2 0 0 2 2 1 1 1 2 1 1 2 -1 2 1 1 2 3 3
Sample Output
3 4
解題思路:這是一道二維樹狀數組入門題---單點修改、單點(區間)查詢,其思路和一維樹狀數組很是類似,多加了一個維度而已。下面咱們來看看怎麼實現這兩個基本操做:
將一維數組A[]擴展到二維數組A[][],二維樹狀數組C[][]來維護矩陣前綴和。
設原始二維數組A[][]={a11,a12,a13,a14,a15,
a21,a22,a23,a24,a25,
a31,a32,a33,a34,a35,
a41,a42,a43,a44,a45,
a51,a52,a53,a54,a55};
那麼二維樹狀數組表示以下:
C[1][1]=a11,C[1][2]=a11+a12,C[1][3]=a13,C[1][4]=a11+a12+a13+a14,C[1][5]=a15
這是數組A[][]第一行的一維樹狀數組;
C[2][1]=a11+a21,C[2][2]=a11+a12+a21+a22,C[2][3]=a13+a23,C[2][4]=a11+a12+a13+a14+a21+a22+a23+a24,C[2][5]=a15+a25
這是數組A[][]第一行和第二行相加後獲得的樹狀數組;
C[3][1]=a31,C[3][2]=a31+a32,C[3][3]=a33,C[3][4]=a31+a32+a33+a34,C[3][5]=a35
這是數組A[][]第三行的一維樹狀數組;
C[4][1]=a11+a21+a31+a41,C[4][2]=a11+a12+a21+a22+a31+a32+a41+a42,C[4][3]=a13+a23+a33+a43...
這是數組A[][]前4行相加後獲得的樹狀數組;
C[5][1]=a51,C[5][2]=a51+a52,C[5][3]=a53,C[5][4]=a51+a52+a53+a54,C[5][5]=a55
這是數組A[][]第5行的一維樹狀數組。
仔細觀察以上式子能夠發現,二維樹狀數組C[x][y]的值實際上是分別在x、y上的一維樹狀數組向下、向右(x上+lowbit(x)跳躍(>n中止),y上+lowbit(y)跳躍(>n中止))進行求和,這就是矩陣中座標點值的單點修改。對於區間查詢,一樣分別在x、y上的一維樹狀數組從下往上,從右往左進行累加(y上-lowbit(y)跳躍(<=0中止),x上-lowbit(x)跳躍(<=0中止)),這樣就獲得了(1,1)到(x,y)矩陣中全部元素的和。
回到本題,題意爲給出一些命令進行一些操做:
0 S 初始化一個全0的S*S矩陣,這個命令只會在第一次給出一次;
1 X Y A 給座標點(X,Y)的值加上A;
2 L B R T 詢問(L,B)到(R,T)構成的矩陣中全部元素的總和;
3 結束對矩陣的操做,程序終止。
典型的二維BIT,套一下模板便可,但須要注意一點:給出命令中的座標都是默認從下標0開始的,爲避免陷入死循環和計算錯誤,在更新和詢問操做上統一對每個座標點(橫、縱座標)加1。
怎麼統計座標點(L,B)到(R,T)矩陣內全部值呢?給出下面的矩陣:
1 2 3 4 5
1 0 0 0 0 0
2 0 0 0 0 0
3 0 0 0 0 0
4 0 0 0 0 0
5 0 0 0 0 0
從圖上可得計算公式:[R,T]-[L-1,T]-[R,B-1]+[L-1,B-1](多減去了一個左上角的矩陣,還要把它加回來),這樣就獲得了點(L,B)到(R,T)矩陣中全部元素的和。
AC代碼:
1 #include<cstdio> 2 #include<string.h> 3 const int maxn=1050; 4 int op,s,x,y,a,l,b,r,t,C[maxn][maxn]; 5 void add(int x,int y,int val){//單點修改 6 for(int i=x;i<=s;i+=i&-i) 7 for(int j=y;j<=s;j+=j&-j) 8 C[i][j]+=val; 9 } 10 int query(int x,int y){//前綴和查詢 11 int ans=0; 12 for(int i=x;i>0;i-=i&-i) 13 for(int j=y;j>0;j-=j&-j) 14 ans+=C[i][j]; 15 return ans; 16 } 17 int main(){ 18 while(~scanf("%d%d",&op,&s)){ 19 memset(C,0,sizeof(C)); 20 while(~scanf("%d",&op)&&op!=3){ 21 if(op==1){ 22 scanf("%d%d%d",&x,&y,&a); 23 x++,y++;add(x,y,a);//單點修改 24 } 25 else{ 26 scanf("%d%d%d%d",&l,&b,&r,&t);l++,b++,r++,t++; 27 printf("%d\n",query(r,t)-query(l-1,t)-query(r,b-1)+query(l-1,b-1));//區間查詢,求矩形中全部元素的和 28 } 29 } 30 } 31 return 0; 32 }