拓撲圖以下:網絡
首先作下幀中繼交換機的配置:ide
FRSwitch:oop
frame-relay switchingrouter
interface s1/0blog
encapsulation frame-relay接口
no shutip
frame-relay intf-type dceci
frame-relay lmi-type cisco路由
clock rate 64000get
interface s1/1
encapsulation frame-relay
no shut
frame-relay intf-type dce
frame-relay lmi-type cisco
clock rate 64000
interface s1/2
encapsulation frame-relay
no shut
frame-relay intf-type dce
frame-relay lmi-type cisco
clock rate 64000
interface s1/3
encapsulation frame-relay
no shut
frame-relay intf-type dce
frame-relay lmi-type cisco
clock rate 64000
接下來,咱們要配置frame-relay route用來定義接口上DLCI並與對端DLCI造成一個PVC
interface s1/0
frame-relay route 102 interface s1/1 100
frame-relay route 103 interface s1/2 130
interface s1/1
frame-relay route 100 interface s1/0 102
interface s1/2
frame-relay route 130 interface s1/0 103
幀中繼交換機的配置咱們已經結束
R1:
interface lo0
ip address 1.1.1.1 255.255.255.0
no shut
exit
interface s1/0
no shut
encapsulation frame-relay
no ip address
interface s1/0.1 multipoint
ip address 192.168.1.101 255.255.255.0
no shut
frame-relay map ip 192.168.1.101 101
frame-relay map ip 192.168.1.102 102 broadcast
frame-relay map ip 192.168.1.103 103 broadcast
用來將IP和DLCI進行一個映射
EIGRP的配置:
router eigrp 90
network 192.168.1.0 0.0.0.255
network 1.1.1.1 0.0.0.0
no auto-summary
eigrp router-id 1.1.1.1
R2:
interface lo0
ip address 2.2.2.2 255.255.255.0
no shut
exit
interface s1/0
encapsulation frame-relay
no shut
no ip address
interface s1/0.1 multipoint
ip add 192.168.1.102 255.255.255.0
no shut
frame-relay map ip 192.168.1.102 100 broadcast
exit
router eigrp 90
network 192.168.1.0 0.0.0.255
network 2.2.2.2 0.0.0.0
no auto-summary
eigrp router-id 2.2.2.2
R3:
interface lo0
ip address 3.3.3.3 255.255.255.0
no shut
exit
interface s1/0
encapsulation frame-relay
no shut
no ip address
interface s1/0.1 multipoint
ip address 192.168.1.103 255.255.255.0
no shut
frame-relay map ip 192.168.1.103 130 broadcast
router eigrp 90
network 192.168.1.0 0.0.0.255
network 3.3.3.3 0.0.0.0
no auto-summary
eigrp router-id 3.3.3.3
驗證結果:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2297856] via 192.168.1.102, 00:28:40, Serial1/0.1
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2297856] via 192.168.1.103, 00:28:40, Serial1/0.1
C 192.168.1.0/24 is directly connected, Serial1/0.1
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2297856] via 192.168.1.101, 00:01:15, Serial1/0.1
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Serial1/0.1
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2297856] via 192.168.1.101, 00:01:21, Serial1/0.1
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Serial1/0.1
看到了吧
R2和R3上彼此的環回口網絡沒有回去由於水平分割的問題
因此須要在R1上的S1/0.1接口上關閉水平分割
interface s1/0.1 multipoint
no ip split-horizon eigrp 90
這樣路由表就能夠獲取了。
這種適合幀中繼全互聯或局部互聯的拓撲結構
下面咱們來配置單點子接口的配置,適用於HUB-SPOKER拓撲結構
幀中繼交換機配置同上
R1:
interface s1/0
encapsulation frame-relay
no shut
interface s1/0.2 point-to-point
ip address 192.168.2.1 255.255.255.0
no shut
frame-relay interface-dlci 102
interface s1/0.3 point-to-point
ip address 192.168.3.1 255.255.255.0
no shut
frame-relay inteface-dlci 103
interface lo0
ip address 1.1.1.1 255.255.255.0
no shut
router eigrp 90
network 192.168.2.0 0.0.0.255
network 192.168.3.0 0.0.0.255
network 1.1.1.1 0.0.0.0
no auto-summary
eigrp router-id 1.1.1.1
R2:
interface lo0
ip address 2.2.2.2 255.255.255.0
no shut
interface s1/0
encapsulation frame-relay
no shut
interface s1/0.2
ip address 192.168.2.2 255.255.255.0
no shut
frame-relay interface-dlci 100
router eigrp 90
network 192.168.2.0 0.0.0.255
network 2.2.2.2 0.0.0.0
no auto-summary
eigrp router-id 2.2.2.2
R3:
interface lo0
ip address 3.3.3.3 255.255.255.0
no shut
interface s1/0
encapsulation frame-relay
no shut
interface s1/0.3
ip address 192.168.3.3 255.255.255.0
no shut
frame-relay interface-dlci 130
router eigrp 90
network 192.168.3.0 0.0.0.255
network 3.3.3.3 0.0.0.0
no auto-summary
eigrp router-id 3.3.3.3
呵呵,配置結束。不用配置水平分割,就能夠獲取全部的路由條目