A1014. Waiting in Line (30)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:ios

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.windows

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.ide

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.spa

Inputcode

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).orm

The next line contains K positive integers, which are the processing time of the K customers.blog

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.ci

Outputinput

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.string

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry
// hahaha.cpp : 定義控制檯應用程序的入口點。
//

#include <stdafx.h>
#include <stdio.h>
#include <iostream>
#include <vector>
#include <queue>
#include <map>
#include <string>
#include <cstdio>
#include <set>
#include <algorithm>
#include <string.h>

using namespace std;

const int maxn=1111;
int n,m,k,query,q;

int cvttime(int h,int m)
    {
    return h*60+m;
    }

struct Window
    {
    int endtime,poptime;
    queue<int> q;
    }window[20];
int ans[maxn],needtime[maxn];

int main()
{
    int index=0;
    scanf("%d%d%d%d",&n,&m,&k,&query);
    for(int i=0;i<k;i++)
        {
        scanf("%d",&needtime[i]);
        }

    for(int i=0;i<n;i++)
        {
        window[i].poptime=window[i].endtime=cvttime(8,0);
        }


    for(int i=0;i<min(n*m,k);i++)//將能入隊的先去排隊
        {
        window[index%n].q.push(index);
        window[index%n].endtime+=needtime[index];
        if(index<n)window[index].poptime=needtime[index];
        ans[index]=window[index%n].endtime;
        index++;
        }
     for(;index<k;index++)
         {
         int idx=-1,minpop=1<<30;
         for(int i=0;i<n;i++)
             {
             if(window[i].poptime<minpop)
                 {
                 idx=i;
                 minpop=window[i].poptime;
                 }
             }
        Window &w=window[idx];
        w.q.pop();
        w.q.push(index);
        w.endtime+=needtime[index];
        w.poptime+=needtime[w.q.front()];
        ans[index]=w.endtime;
         }

     for(int i=0;i<query;i++)
         {
         scanf("%d",&q);
         if(ans[q-1]-needtime[q-1]>=cvttime(17,0))
             printf("Sorry\n");
         else
             {
             printf("%02d:%02d\n",ans[q-1]/60,ans[q-1]%60);
             }
         }
    return 0;
}
相關文章
相關標籤/搜索