HDU 4708:Rotation Lock Puzzle

Rotation Lock Puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1836    Accepted Submission(s): 580


Problem Description
Alice was felling into a cave. She found a strange door with a number square matrix. These numbers can be rotated around the center clockwise or counterclockwise. A fairy came and told her how to solve this puzzle lock: 「When the sum of main diagonal and anti-diagonal is maximum, the door is open.」.
Here, main diagonal is the diagonal runs from the top left corner to the bottom right corner, and anti-diagonal runs from the top right to the bottom left corner. The size of square matrix is always odd.



This sample is a square matrix with 5*5. The numbers with vertical shadow can be rotated around center ‘3’, the numbers with horizontal shadow is another queue. Alice found that if she rotated vertical shadow number with one step, the sum of two diagonals is maximum value of 72 (the center number is counted only once).
 

Input
Multi cases is included in the input file. The first line of each case is the size of matrix n, n is a odd number and 3<=n<=9.There are n lines followed, each line contain n integers. It is end of input when n is 0 .
 

Output
For each test case, output the maximum sum of two diagonals and minimum steps to reach this target in one line.
 

Sample Input
  
  
  
  
  
5 9 3 2 5 9 7 4 7 5 4 6 9 3 9 3 5 2 8 7 2 9 9 4 1 9 0
 

Sample Output
  
  
  
  
  
72 1
 

Source
 

迷失在幽谷中的鳥兒,獨自飛翔在這偌大的天地間,殊不知本身該飛往何方……


題意:給出一個n*n矩陣,n>=3&&n<=9,若是按照最大可能性,只有第二層和第四層有多是垂直線段覆蓋區域!垂直區域能夠向逆時針或者順時針旋轉,求旋轉幾回可使構成的新矩陣主對角線和副對角線的和最大!
一道簡單可暴力解決的題目!由於n<=9!


#include<stdio.h>
#include<iostream>
using namespace std;
int ab[10][10];
int tl,tr,bl,br;
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                scanf("%d",&ab[i][j]);
        int add=0,kk=0;
        for(int i=1; i<=(n-1)/2; i++)
        {
            int sum=-0xffffff,ji=0;
            for(int j=0; j<n-(i*2-1); j++)
            {
                tl=ab[i+j][i];
                tr=ab[i][n-i+1-j];
                bl=ab[n-i+1][i+j];
                br=ab[n-i+1-j][n-i+1];
                int oth=tl+tr+bl+br;
                if(oth>sum)sum=oth,ji=j;
                else if(oth==sum&&j<ji)ji=j;
            }
            for(int j=0; j<n-(i*2-1); j++)
            {
                tl=ab[i][i+j];
                tr=ab[i+j][n-i+1];
                bl=ab[n-i+1-j][i];
                br=ab[n-i+1][n-i+1-j];
                int oth=tl+tr+bl+br;
                if(oth>sum)sum=oth,ji=j;
                else if(oth==sum&&j<ji)ji=j;
            }
            add+=sum;
            kk+=ji;
        }
        printf("%d %d\n",ab[(n+1)/2][(n+1)/2]+add,kk);
    }
    return 0;
}
相關文章
相關標籤/搜索