(並查集) HDU 1856 More is better

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

 

Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
 

 

Sample Output
4
2
 
 
 
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 
 
 這個是裸的並查集,就是求幾個並查集中的空間最大的數,也就是求其中結點數最多的一個並查集裏面的結點的個數。注意紮實基礎。
C++代碼:
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn = 10000004;
int father[maxn],num[maxn];
int maxm;
int Find(int x){
    while(x != father[x]){
        father[x] = father[father[x]];
        x = father[x];
    }
    return x;
}
void Union(int a,int b){
    int ax = Find(a);
    int bx = Find(b);
    if(ax!=bx){
        father[ax] = bx;
        num[bx] += num[ax];   //注意這是以bx爲根的,因此固然要讓num[bx]增長。 
        if(maxm < num[bx]){
            maxm = num[bx];
        }
    }
}
int main(){
    int T;
    while(~scanf("%d",&T)){
        if(T == 0){
            cout<<1<<endl;
            continue;
        }
        for(int i = 1; i < 10000001; i++){
            father[i] = i;
            num[i] = 1;
        }
        int a,b;
        maxm = -1;
        for(int i = 1; i <= T; i++){
            scanf("%d%d",&a,&b);
            Union(a,b);    
        }
        cout<<maxm<<endl;
    }
    return 0;
}
相關文章
相關標籤/搜索