Collecting Bugs
Time Limit: 10000MS |
|
Memory Limit: 64000K |
Total Submissions: 1716 |
|
Accepted: 783 |
Case Time Limit: 2000MS |
|
Special Judge |
Descriptionios
Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan's work) required to name the program disgusting.
Inputgit
Input file contains two integer numbers, n and s (0 < n, s <= 1 000).
Outputapp
Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.
Sample Inputpost
1 2
Sample Outputui
3.0000
題目大意:一個軟件有s個子系統,會產生n種bug。某人一天發現一個bug,這個bug屬於某種bug,發生在某個子系統中。求找到全部的n種bug,且每一個子系統都找到bug,這樣所要的天數的指望。
解題方法:機率DP,dp[i][j]表示已經找到i種bug,並存在於j個子系統中,要達到目標狀態的天數的指望。顯然,dp[n][s]=0,由於已經達到目標了。而dp[0][0]就是咱們要求的答案。dp[i][j]狀態能夠轉化成如下四種:dp[i][j] 發現一個bug屬於已經找到的i種bug和j個子系統中dp[i+1][j] 發現一個bug屬於新的一種bug,但屬於已經找到的j種子系統dp[i][j+1] 發現一個bug屬於已經找到的i種bug,但屬於新的子系統dp[i+1][j+1]發現一個bug屬於新的一種bug和新的一個子系統因此dp[i][j] = i/n*j/s*dp[i][j] + i/n*(s-j)/s*dp[i][j+1]+ (n-i)/n*j/s*dp[i+1][j] + (n-i)/n*(s-j)/s*dp[i+1][j+1] + 1;
經過化簡獲得公式:dp[i][j] = (p1 + p2 + p3 + n * s) / (n * s - i * j);
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
double dp[1005][1005];
int main()
{
int n, s;
scanf("%d%d", &n, &s);
for (int i = n; i >= 0; i--)
{
for (int j = s; j >= 0; j--)
{
if (i == n && j == s)
{
continue;
}
double p1 = dp[i + 1][j] * (n - i) * j;
double p2 = dp[i][j + 1] * i * (s - j);
double p3 = dp[i + 1][j + 1] * (n - i) * (s - j);
dp[i][j] = (p1 + p2 + p3 + n * s) / (n * s - i * j);
}
}
printf("%.4f\n", dp[0][0]);
return 0;
}