poj 1274 The Perfect Stall


The Perfect Stall

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16888 Accepted: 7721

Description 算法

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input dom

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output ui

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input spa

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

Sample Output .net

4

Source code


個人解答:

二分圖匹配.匈牙利算法. ip


/*=============================================================================
#     FileName: 1274.cpp
#         Desc: poj 1274
#       Author: zhuting
#        Email: cnjs.zhuting@gmail.com
#     HomePage: my.oschina.net/locusxt
#      Version: 0.0.1
#    CreatTime: 2013-12-07 15:54:43
#   LastChange: 2013-12-07 15:54:43
#      History:
=============================================================================*/
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#define maxn 205

bool mymap[maxn][maxn] = {0};/*記錄是否兩點相連*/
int link[maxn] = {0};/*記錄右邊的點所鏈接的點,沒有時置-1*/
bool cover[maxn] = {0};/*記錄右邊的某個點有沒有被覆蓋,防止死循環*/
int n = 0, m = 0;

bool find (int x)/*尋找左邊的點*/
{
	for (int i = 0; i < m; ++i)/*對右邊的點進行遍歷*/
	{
		if (!cover[i] && mymap[x][i])/*若是該右點沒有被覆蓋,而且與左點x之間有線相連*/
		{
			cover[i] = 1;
			if (link[i] == -1 || find(link[i]))
			{
				link[i] = x;
				return 1;
			}
		}
	}
	return 0;
}

void init()
{
	memset(mymap, 0, sizeof(mymap));
	memset(cover, 0, sizeof(cover));
	memset(link, 0xff, sizeof(link));
	return;
}

int main()
{
	int link_num = 0;
	int stall = 0;
	while (scanf("%d%d", &n, &m) != EOF)
	{
		int ans = 0;
		init();
		for (int i = 0; i < n; ++i)
		{
			scanf("%d", &link_num);
			for (int j = 0; j < link_num; ++j)
			{
				scanf("%d", &stall);
				mymap[i][stall - 1] = 1;
			}
		}
		for (int i = 0; i < n; ++i)/*遍歷全部左點*/
		{
			memset(cover, 0, sizeof(cover));
			if (find(i))
				++ans;
		}
		printf("%d\n", ans);
	}
	return 0;
}


第一道二分圖,匈牙利算法 ci

相關文章
相關標籤/搜索