The Suspects
Time Limit: 1000MS |
|
Memory Limit: 20000K |
Total Submissions: 18859 |
|
Accepted: 9130 |
Descriptionide
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Inputthis
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Outputspa
For each case, output the number of suspects in one line.
Sample Inputcode
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Outputblog
4
1
1
題目大意:第0號同窗感染了SARS病毒,凡是與第0號同窗一個社團的都爲病毒感染嫌疑人,並且與這些嫌疑人一個社團的的人都爲病毒感染嫌疑人,找出SARS病毒感染者嫌疑人數。
解題方法:並查集,每次統計每一個集合中嫌疑人的個數,合併時將子節點的數目加到父節點。
#include <stdio.h>
typedef struct
{
int nCount;
int parent;
int rank;
}UFSTree;
UFSTree Student[30005];
void MakeSet(int n)
{
for (int i = 0; i <= n; i++)
{
Student[i].nCount = 1;
Student[i].parent = i;
Student[i].rank = 0;
}
}
int FindSet(int x)
{
if (x != Student[x].parent)
{
return FindSet(Student[x].parent);
}
else
{
return x;
}
}
void UnionSet(int x, int y)
{
x = FindSet(x);
y = FindSet(y);
if (Student[x].rank > Student[y].rank)
{
Student[y].parent = x;
Student[x].nCount += Student[y].nCount;
}
else
{
Student[x].parent = y;
Student[y].nCount += Student[x].nCount;
if (Student[x].rank == Student[y].nCount)
{
Student[y].rank++;
}
}
}
int main()
{
int n, m, k, x, y;
while(scanf("%d%d", &n, &m) != EOF && (n != 0 || m != 0))
{
MakeSet(n);
for (int i = 0; i < m; i++)
{
scanf("%d", &k);
scanf("%d", &x);
for (int j = 1; j < k; j++)
{
scanf("%d", &y);
if (FindSet(x) != FindSet(y))
{
UnionSet(x, y);
}
}
}
printf("%d\n", Student[FindSet(0)].nCount);
}
return 0;
}