HDU 3999 The order of a Tree

The order of a Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 845    Accepted Submission(s): 461


node

Problem Description
As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1.  insert a key k to a empty tree, then the tree become a tree with
only one node;
2.  insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert 「the order of a tree」,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.
 

 

Input
There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.
 

 

Output
One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.
 

 

Sample Input
4 1 3 4 2
 

 

Sample Output
1 3 2 4
題目大意:簡歷一顆二叉排序樹,而後先序遍歷。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <stack>
using namespace std;

typedef struct node
{
    int data;
    node *lchild;
    node *rchild;
    node()
    {
        lchild = rchild = NULL;
    }
}TreeNode;

void CreateTree(TreeNode *&pRoot, int data)
{
    if (pRoot == NULL)
    {
        pRoot = new TreeNode;
        pRoot->data = data;
    }
    else
    {
        if (data > pRoot->data)
        {
            CreateTree(pRoot->rchild, data);
        }
        else
        {
            CreateTree(pRoot->lchild, data);
        }
    }
}

void PreOrder(TreeNode *pRoot)
{
    int nCount = 0;
    if (pRoot == NULL)
    {
        return;
    }
    stack<TreeNode*> Stack;
    Stack.push(pRoot);
    do 
    {
        TreeNode *p = Stack.top();
        Stack.pop();
        if (nCount == 0)
        {
            printf("%d", p->data);
            nCount++;
        }
        else
        {
            printf(" %d", p->data);
            nCount++;
        }
        if (p->rchild != NULL)
        {
            Stack.push(p->rchild);
        }
        if (p->lchild != NULL)
        {
            Stack.push(p->lchild);
        }

    } while (!Stack.empty());
}

int main()
{
    int n, num;
    scanf("%d", &n);
    TreeNode *pRoot = NULL;
    for (int i = 0; i < n; i++)
    {
        scanf("%d", &num);
        CreateTree(pRoot, num);
    }
    PreOrder(pRoot);
    printf("\n");
    return 0;
}
相關文章
相關標籤/搜索