1009 Product of Polynomials (25)(25 分)

1009 Product of Polynomials (25)(25 分)

This time, you are supposed to find A*B where A and B are two polynomials.node

Input Specification:ios

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.數組

Output Specification:spa

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.code

Sample Inputorm

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Outputblog




英語很差真是硬傷!!!!
每行表明一個多項式 第一個數是多項式包含的項數 , 後面依次是 指數 係數
計算的過程當中 , 先 輸入一個多項式, 而後第二個多項式的每一項和第一個多項式相乘
指數相加, 係數相乘
用數組下標表示指數,指數相同的項 合併同類項, 數組下標對應的數值是多項式相乘結果的係數。

最後按照多項式係數從高到低輸出多項式便可

3 3 3.6 2 6.0 1 1.6
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>

using namespace std ; 

#define maxn 3000

struct node{
    int exp;  // 指數
    double cof ; // 係數
};

node poly[2000] ; // 表示多項式的每一項
double result[maxn] ; // i 對應多項式的指數, result[i] 對應多項式的係數
int k1, k2 ; 

int main(){

    memset(result, 0, sizeof(result)) ; 
    // 先輸入一個多項式       
    cin >> k1 ; 
    for(int i=0 ; i<k1 ; i++){
        cin >> poly[i].exp >> poly[i].cof ; 
    }

    cin >> k2 ;
    int exp ;
    double cof ; 

    for(int j=0 ; j<k2 ; j++){
        cin >> exp >> cof ; 
        for(int i=0 ; i<k1 ; i++){
            // 第二個多項式的每一項都和 第一個多項式全部項相乘
            result[exp + poly[i].exp] += (cof * poly[i].cof) ; 
        }
    }

    int numbers = 0 ; 
    // 統計 指數 i 的係數 result[i] 不爲 0 的全部個數
    for(int i=0 ; i<maxn ; i++){
        if(result[i] != 0 ){
            numbers ++ ; 
        }
    }

    //   按照多項式指數從高到低 輸出多項式的全部項
    cout << numbers ; 
    for(int i=maxn-1 ; i>=0 ; i--){
        if(result[i] != 0 ){
            printf(" %d %.1f", i, result[i]) ; 
        }
    }

    return 0 ; 
}
相關文章
相關標籤/搜索