hdoj:2085

核反應堆

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15706    Accepted Submission(s): 7036



Problem Description
某核反應堆有兩類事件發生:
高能質點碰擊核子時,質點被吸取,放出3個高能質點和1個低能質點;
低能質點碰擊核子時,質點被吸取,放出2個高能質點和1個低能質點。
假定開始的時候(0微秒)只有一個高能質點射入核反應堆,每一微秒引發一個事件發生(對於一個事件,當前存在的全部質點都會撞擊核子),試肯定n微秒時高能質點和低能質點的數目。

 

Input
輸入含有一些整數n(0≤n≤33),以微秒爲單位,若n爲-1表示處理結束。
 

Output
分別輸出n微秒時刻高能質點和低能質點的數量,高能質點與低能質點數量之間以逗號空格分隔。每一個輸出佔一行。
 

Sample Input
  
  
  
  
5 2 -1
 

Sample Output
  
  
  
  
571, 209 11, 4 提示 可使用long long int對付GNU C++,使用__int64對付VC6
#include <iostream>
#include <string>
#include <vector>

using namespace std;

#define limit 34

void f(long long x, long long &a, long  long &b)
{
    a += 3 * x;
    b += x;
}
void g(long long x, long long &a, long long &b)
{
    a += 2 * x;
    b += x;
}
long long a[limit];
long long b[limit];
int main()
{
    int n;
    a[0] = 1;
    b[0] = 0;
    
    for (int i = 1; i < limit; i++)
    {
        f(a[i - 1], a[i], b[i]);
        g(b[i-1], a[i], b[i]);
    }
    while (true)
    {
        cin >> n;
        if (n == -1)
            break;

        cout << a[n] <<", "<<b[n]<< endl;
    }
    return 0;
}
相關文章
相關標籤/搜索