HDOJ--2680--Choose the best route

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10372    Accepted Submission(s): 3342


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output 「-1」.
 

Sample Input
   
   
   
   
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
   
   
   
   
1 -1
題意:琪琪想要去拜訪她的朋友,但是這貨easy暈車,因此要找一個花費時間最少的路線。

現在給你路線圖。讓你找出從她家附近的起點站(可以有多個)到朋友家附近的終點站(僅僅有一個)花費時間最少的路線。各個網站的編號從1到n。 node

思路:最開始我是直接無腦用DIJ算法作的結果絲絕不意外(TLE)了,FUCK。看了看別人的思路才造應該把終點當起點反向構圖,注意,這是個單向圖。
AC代碼:
#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
int vis[1010],map[1010][1010],dis[1010],n,ans[1010],num,beg;
void init(){
	for(int i=1;i<=n;i++)
		for(int j=0;j<=n;j++){
			if(i==j)
				map[i][j]=map[j][i]=0;
			else
				map[i][j]=map[j][i]=INF;
		}
}
void dijkstra(){
	int k=0,flag=0,i;
		memset(vis,0,sizeof(vis));
		for(i=1;i<=n;i++)
			dis[i]=map[beg][i];
		vis[beg]=1;
		for(i=1;i<=n;i++){
			int j,key,temp=INF;
			for(int j=1;j<=n;j++)
				if(!vis[j]&&temp>dis[j])
					temp=dis[key=j];
			if(temp==INF){
				break;
			}
			vis[key]=1;
			for(int j=1;j<=n;j++)
				if(!vis[j]&&dis[j]>dis[key]+map[key][j])
					dis[j]=dis[key]+map[key][j];
		}
}
int main(){
	int m;
	while(scanf("%d%d%d",&n,&m,&beg)!=EOF){
		int i;
		memset(ans,INF,sizeof(INF));
		init();//注意要初始化。 
		for(i=1;i<=m;i++){
			int a,b,cost;
			scanf("%d%d%d",&a,&b,&cost);
			if(map[b][a]>cost)//過濾掉一樣的邊。反向構圖。

map[b][a]=cost; } scanf("%d",&num); dijkstra();//直接找到各個終點的位置。 for(i=0;i<num;i++){ int end; scanf("%d",&end); ans[i]=dis[end]; } sort(ans,ans+num); if(ans[0]==INF)//推斷是否存在這種值。不存在的話ans數組確定每一個都是INF。 printf("-1\n"); else printf("%d\n",ans[0]); } return 0; }算法

再次使用SPFA過一次。這道題很是坑,哦,不,很是坑。假設你數組開小了。用G++提交會顯示超時而不是RE,不明覺厲。
ac代碼:
#include<stdio.h>
#include<string.h>
#include<queue>
#define INF 0x3f3f3f3f
#define N 1010
#define M 20100
using namespace std;
int dis[N],vis[N],n,m,edgenum,head[N];
struct node{
	int from,to,cost,next;
}edge[M];//結構體是用來記錄邊的數量的。應該開到M; 
void init(){
	edgenum=0;
	memset(head,-1,sizeof(head));//表頭應注意初始時爲-1。 
}
void add(int u,int v,int cost){
	node E={u,v,cost,head[u]};
	edge[edgenum]=E;
	head[u]=edgenum++;
}
void spfa(int beg){
	queue<int>q;
	memset(dis,INF,sizeof(dis));
	memset(vis,0,sizeof(vis));
	dis[beg]=0;
	vis[beg]=1;
	q.push(beg);
	while(!q.empty()){
		int i,u=q.front();
		q.pop();
		vis[u]=0;
		for(i=head[u];i!=-1;i=edge[i].next){
			int v=edge[i].to;
			if(dis[v]>dis[u]+edge[i].cost){
				dis[v]=dis[u]+edge[i].cost;
				if(!vis[v]){
					vis[v]=1;
					q.push(v);
				}
			}
		}
	}
}
int main(){
	int beg;
	while(scanf("%d%d%d",&n,&m,&beg)!=EOF){
		init();
		while(m--){
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			add(b,a,c);
		}
		spfa(beg);
		int e,min=INF;
		scanf("%d",&e);
		while(e--){
			int end;
			scanf("%d",&end);
			if(min>dis[end])
				min=dis[end];
		}
		if(min==INF)
			printf("-1\n");
		else
			printf("%d\n",min);
	}
	return 0;
}
相關文章
相關標籤/搜索