主要思路:ide
(1)對於交換機:測試
1:命名router
2:劃分VLANblog
3:將指定端口劃分到指定vlanip
4:將指定端口設置成trunk模式路由
(2)對於PC:(這裏把router當作是PC)文檔
1:命名terminal
2:禁止路由功能get
3:設置IPit
4:ping IP
(3)查看配置命令:
查看vlan :show vlan-switch
查看trunk: show interface f0/0 switchport
----------------------------------------------
配置文檔:
sw1:
enable
config terminal
hostname sw1 //命名
exit
vlan database //添加VLAN並命名
vlan 2 name v2
vlan 3 name v3
exit
config terminal //將端口添加到指定的VLAN
interface f0/1
switchport access vlan 2
exit
interface f0/2 //將端口添加到指定的VLAN
switchport access vlan 3
exit
interface f0/0 //將指定端口設置成trunk
switchport mode trunk
end
write
----------------------------------------------
sw2:
enable //命名
config terminal
hostname sw2
exit
vlan database //添加VLAN並命名
vlan 2 name v2
vlan 3 name v3
exit
config terminal //將指定端口添加到指定VLAN
interface f0/2
switchport access vlan 2
exit
interface f0/3 //將指定端口添加到指定VLAN
switchport access vlan 3
exit
interface f0/0 //將指定端口設置成trunk
switchport mode trunk
end
write
----------------------------------------------
pc1:
enable
config terminal
hostname pc1 //命名
no ip routing //禁止路由功能
interface f0/0
ip address 192.168.1.1 255.255.255.0 //設置IP
no shutdown //激活
end
write
-----------------------------------------------
pc2:
enable
config terminal
hostname pc2 //命名
no ip routing //禁止路由功能
interface f0/0
ip address 192.168.1.2 255.255.255.0 //設置IP
no shutdown //激活
end
write
-----------------------------------------------
pc3:
enable
config terminal
hostname pc3 //命名
no ip routing //禁止路由功能
interface f0/0
ip address 192.168.1.3 255.255.255.0 //設置IP
no shutdown //激活
end
write
-----------------------------------------------
pc4:
enable
config terminal
hostname pc4 //命名
no ip routing //禁止路由功能
interface f0/0
ip address 192.168.1.4 255.255.255.0 //設置IP
no shutdown //激活
end
write
-----------------------------------------------
測試截圖:
(1)在SW1上查看VLAN 信息:
(2)在SW1上查看F0/0端口模式:
(3)在SW2上查看VLAN 信息:
(4)在SW2上查看F0/0端口模式:
(5)在PC1上對其它PC進行PING命令:
(5)在PC2上對其它PC進行PING命令:
註明:
由於pc1和pc3都屬於vlan2,因此可以PING通,
PC2與PC4都屬於vlan3,因此它們也可以PING通。
可是PC1和PC3與PC2和PC4是不可以PING通的。。