ZOJ 2158 Truck History

題目連接

Truck History

Time Limit: 5 Seconds Memory Limit: 32768 KB
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.ios

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined asthis

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.spa

Input Specification

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.code

Output Specification

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.ci

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0get

Sample Output

The highest possible quality is 1/3.input

分析:

要使派生方案的優劣值最大,就要使分母最小。另外,要考慮全部類型對(t0,td)的距離,使得最終派生方案中每種卡車類型都是一種卡車類型派生出來(最初卡車類型除外)。這樣每種卡車類型理解爲無向圖中的點,所求最佳方案就是求最小生成樹,而分母就是最小生成樹的權string

AC代碼
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=2010;
const int inf=0x3f3f3f3f3f;
char s[N][8];
int e[N][N],dis[N];
bool vis[N];
int n;

int Prim(int st){
    int ans=0;
    memset(vis,false, sizeof(vis));
    vis[st]=true;
    for(int i=1;i<=n;i++){
        dis[i]=e[st][i];
    }
    int minn,u;
    for(int i=1;i<n;i++){
        minn=inf;
        for(int j=1;j<=n;j++){
            if(minn>dis[j]&&!vis[j]){
                minn=dis[j];
                u=j;
            }
        }
        if(minn==inf) break;
        vis[u]=true;
        ans+=minn;
        for(int j=1;j<=n;j++){
            if(dis[j]>e[u][j]&&!vis[j]) dis[j]=e[u][j];
        }
    }
    return ans;
}
int main(){
    while(scanf("%d",&n)&&n){
        for(int i=1;i<=n;i++){
            scanf("%s",s[i]);
        }
        for(int i=1;i<=n;i++){
            for(int j=i+1;j<=n;j++){
                int t=0;
                for(int  k=0;k<7;k++){
                    if(s[i][k]!=s[j][k]) t++;
                }
                e[i][j]=e[j][i]=t;
            }
        }
        int ans=Prim(1);
        printf("The highest possible quality is 1/%d.\n",ans);
    }
    return 0;
}
相關文章
相關標籤/搜索