poj2456

Aggressive cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 24979   Accepted: 11594

Descriptionios

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input算法

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Outputui

* Line 1: One integer: the largest minimum distance

Sample Inputthis

5 3
1
2
8
4
9

Sample Outputspa

3

Hintcode

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Sourceblog

一句話題意:
有n個牛欄,k頭牛。將這k頭牛放入牛欄中,如何保證牛與牛之間最小的距離最大。
解析:
明顯的是二分算法。
L=0;R= 最大值
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100010;
int n,k;
int a[maxn];
int check(int x){
    int cnt=1;
    int y=a[1];
    for(int i=2;i<=n;i++)
        if(a[i]-y>=x){
            cnt++;y=a[i];
            if(cnt>=k) return 1;
        }
    return 0;
}
int main(){
    cin>>n>>k;
    for(int i=1;i<=n;i++){
        cin>>a[i];
    }
    sort(a+1,a+1+n);
    int l=0,r=a[n],mid;
    while (l<r){
        mid=(l+r+1)/2;
        if(check(mid)) l=mid;
        else r=mid-1;    
    }
    cout<<l<<endl;
    return 0;
}
相關文章
相關標籤/搜索