PAT (A) 1012 The Best Rank

1.問題

1012 The Best Rank(25分)ios

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only:C- C Programming Language,M- Mathematics (Calculus or Linear Algrbra), andE- English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.git

For example, The grades ofC,M,EandA- Average of 4 students are given as the following:數組

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.ide

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbersNandM(≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. ThenNlines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order ofC,MandE. Then there areMlines, each containing a student ID.lua

Output Specification:

For each of theMstudents, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.spa

The priorities of the ranking methods are ordered asA>C>M>E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.code

If a student is not on the grading list, simply outputN/A.orm

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

2.代碼

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

const int N = 2010;

const int M = 1000000;

struct student{
    int id;
    int grade[4];
}stu[N];

int Rank[M][4];
int now;

char course[4] = {'A', 'C', 'M', 'E'};

bool cmp(student a, student b)
{
    return a.grade[now] > b.grade[now];
}

int main()
{
    //freopen("test.txt","r",stdin);
    
    int n, m;
    
    scanf("%d %d", &n, &m);
    for (int i = 0; i < n; i ++)
    {
        scanf("%d %d %d %d", &stu[i].id, &stu[i].grade[1], &stu[i].grade[2], &stu[i].grade[3]);
        stu[i].grade[0] = round((stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3]) / 3 + 0.5);    
    }
    
    for (now = 0; now < 4; now ++)
    {
        sort(stu, stu + n, cmp);
        
        Rank[stu[0].id][now] = 1;
        for (int i = 1; i < n; i ++)
            if(stu[i].grade[now] == stu[i - 1].grade[now]) 
                Rank[stu[i].id][now] = Rank[stu[i - 1].id][now];
            else Rank[stu[i].id][now] = i + 1;
    }
    
    int query;
    for (int i = 0; i < m; i ++)
    {
        scanf("%d", &query);
        if(Rank[query][0] == 0)
            printf("N/A\n");
        else
        {    int k = 0;
            for (int j = 0;  j < 4; j ++)
            {
                if(Rank[query][j] < Rank[query][k])
                    k = j;
            }
            
            printf("%d %c\n", Rank[query][k], course[k]);
        }
    }
    return 0;
}

3.總結

  • (1) 出現的問題:排序

    • 剛開始將分數分別定義在結構體中,在以後對分數進行排序時,沒法經過循環將功能相同但變量沒法統一的一段代碼實現。
    • 當名次相同時,須要按照 A > C > M > E 進行輸出。
  • (2)解決:three

    • 使用數組來表示4個不一樣科目的分數,進行排序時,可使用一個變量來對不一樣學生的不一樣成績進行排序。
    • 定義一個優先級字符數組,按照此優先級進行輸出。
相關文章
相關標籤/搜索