2017級寒假講座二分三分訓練題A - Cable master (浮點數二分法將其轉化成整數進行)

題目:A - Cable master
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output
2.00ios

大意:就是從所給出的每一個繩子,要分出11段徹底相同的,而後輸出能分的最大的長度;git

思路:這裏用二分法進行,能分出來的長度只可能從0到最大的繩子的長度之間,因此二分時只須要在這個範圍內二分便可;而後二分出來的值看可否讓其湊出11段;promise

注意:這個由於是要求比較精確的狀況,即保留兩位小數點的時候,因此儘可能避免直接用浮點數來進行,而是要轉換成整型來進行;(由於浮點數的精度問題會很難受,因此要特別注意!)(這個轉化成整型,即成100來進行);ide

新技巧:之後對於這類的浮點數的二分時,將其轉化成整型進行二分;(若是擴大倍數的,以後別忘再縮回來);this

代碼:spa

#include <iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
        int len[10005];
int main(){
    long n,k,ks,i;
    while(scanf("%ld%ld",&n,&k)!=EOF){
        int  ans,left=0,maxs=0,mid;

        double input[10005];
        for(i=0;i<n;i++){
            scanf("%lf",&input[i]);
            len[i]=input[i]*100;
            maxs=maxs>len[i]?maxs:len[i];
        }
        while(maxs>=left){
            ks=0;
            ans=(maxs+left)/2;
            if(!ans){
                mid=ans;
                break;
            }
            for(i=0;i<n;i++)
                ks+=len[i]/ans;
            if(ks>=k){
                left=ans+1;
                mid=ans;
            }
            else
                maxs=ans-1;
        }
        printf("%.2f\n",(double)mid/100);
    }
    return 0;
}
相關文章
相關標籤/搜索