3676: [Apio2014]迴文串

3676: [Apio2014]迴文串ios

Time Limit: 20 Sec Memory Limit: 128 MB
Submit: 1740 Solved: 744
[Submit][Status][Discuss]
Descriptionc++

考慮一個只包含小寫拉丁字母的字符串s。咱們定義s的一個子串t的「出
現值」爲t在s中的出現次數乘以t的長度。請你求出s的全部迴文子串中的最
大出現值。spa

Inputcode

輸入只有一行,爲一個只包含小寫字母(a -z)的非空字符串s。ip

Output字符串

輸出一個整數,爲逝查迴文子串的最大出現值。get

Sample Inputstring

【樣例輸入l】it

abacabaio

【樣例輸入2]

www

Sample Output

【樣例輸出l】

7

【樣例輸出2]

4

HINT

一個串是迴文的,當且僅當它從左到右讀和從右到左讀徹底同樣。

在第一個樣例中,迴文子串有7個:a,b,c,aba,aca,bacab,abacaba,其中:

● a出現4次,其出現值爲4:1:1=4

● b出現2次,其出現值爲2:1:1=2

● c出現1次,其出現值爲l:1:l=l

● aba出現2次,其出現值爲2:1:3=6

● aca出現1次,其出現值爲1=1:3=3

●bacab出現1次,其出現值爲1:1:5=5

● abacaba出現1次,其出現值爲1:1:7=7

故最大回文子串出現值爲7。

【數據規模與評分】

數據知足1≤字符串長度≤300000。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<queue>
using namespace std;
#define LL long long
int read()
{
    int s=0,f=1;char ch=getchar();
    while(!('0'<=ch&&ch<='9')){if(ch=='-')f=-1;ch=getchar();}
    while('0'<=ch&&ch<='9'){s=(s<<3)+(s<<1)+ch-'0';ch=getchar();}
    return s*f;
}
int n;
char z[300005];
int fa[300005],l[300005],las,np,ch[300005][26];
LL siz[300005],ans;
int main()
{
    //freopen(".in","r",stdin);
    //freopen(".out","w",stdout);
    scanf("%s",z+1);
    n=strlen(z+1);
    np++;fa[0]=fa[1]=1;l[1]=-1;
    for(int i=1;i<=n;i++)
       {int &x=las;
        while(z[i-l[x]-1]!=z[i])x=fa[x];
        if(!ch[x][z[i]-'a'])
           {int to=++np,k=fa[x];//cout<<k<<" ";
            l[to]=l[x]+2;
            while(z[i-l[k]-1]!=z[i])k=fa[k];
            fa[to]=ch[k][z[i]-'a'];ch[x][z[i]-'a']=to;
           }
        x=ch[x][z[i]-'a'];
        siz[x]++;
       }
    for(int i=np;i;i--)
       {siz[fa[i]]+=siz[i];
        ans=max(ans,siz[i]*l[i]);
       }
    printf("%lld\n",ans);
    //fclose(stdin);
    //fclose(stdout);
    return 0;
}
相關文章
相關標籤/搜索