HDOJ 1019

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33105    Accepted Submission(s): 12478


spa

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

 

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
 

 

Sample Output
105 10296
 
代碼:
#include "stdio.h"
int leastCommon(int a,int b)
{
   if(b==0) return a;
   return leastCommon(b,a%b);
}
int main()
{
    int n,m,t1,t2;
    while(scanf("%d",&n)!=-1)
    {
        while(n--)
        {
            scanf("%d",&m);
            scanf("%d",&t1);
            m--;
            while(m--)
            {
                scanf("%d",&t2);
                t1=t1/leastCommon(t1,t2)*t2;
            }
            printf("%d\n", t1);
        }
     
    }
}

這個須要注意:orm

t1=t1/leastCommon(t1,t2)*t2;
若是寫成
t1=t1*t2/leastCommon(t1,t2);  就會越界!
相關文章
相關標籤/搜索