Image Perimeters

Description

給出一張由"x"和"."組成的矩陣。每一個"x"能夠向上下左右及兩個斜對角進行連通,請問由某個點開始的"x",它所連通的圖形的周長爲多少。node

Input

整個測試有多組數據,整個測試以四個零表明結束。
對於每一個數據,第一行給出整個圖形的大小(長度小於50),再給出開始點的座標。接下來若干行用於描述這個圖形。c++

Output

如題測試

Sample Input

2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
...X
..X.
X...
5 6 1 3
.XXXX.
X....X
..XX.X
.X...X
..XXX.
7 7 2 6
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
7 7 4 4
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
0 0 0 0spa

Sample Output

8
18
40
48
8code

這道題是找連通塊,只是多了斜線,算周長只要在四周打點,ans++,剩下就是BFS平常操做。ip

八個方向:ci

int dir[8][2]={{0,1},{1,0},{-1,0},{0,-1},{1,1},{1,-1},{-1,1},{-1,-1}};

結構體:input

struct node{
	int x;
	int y;
	node(){ };
	node (int sx,int sy){
		x=sx;
		y=sy;
	}
};

BFS主體:it

void bfs(int x,int y){
	q1.push(node(x,y));
	vis[x][y]=1;
	while(!q.empty()){
		node prg = q.front();
		q.pop();
		
		
		for(int i=0;i<8;i++){
			int tx = prg.x+dir[i][0];
			int ty = prg.y+dir[i][1]; 
		
		
			if(!vis[tx][ty]&&mp[tx][ty] == 'X'){
				q.push(node(tx,ty));
				q1.push(node(tx,ty));
				vis[tx][ty]=1;
			}
		}
	} 
}

打點,計算答案:io

void change(){
	for(int i=0;i<=n+1;i++){
		for(int j=0;j<=m+1;j++){
			if(mp[i][j]!='X'&&mp[i][j]!='.'){
					mp[i][j]='.';
			}
		}
	}
		q.push(node(x,y));
		bfs(x,y);
	while(!q1.empty()){
			node prg = q1.front();
			q1.pop();
		for(int i=0;i<4;i++){
				int tx=prg.x+dir[i][0];
				int ty=prg.y+dir[i][1];
			if(mp[tx][ty]=='.'){
					ans++;
			}
		}
	}
}

完整代碼:

#include<bits/stdc++.h>
using namespace std;

int ans=0;

int dir[8][2]={{0,1},{1,0},{-1,0},{0,-1},{1,1},{1,-1},{-1,1},{-1,-1}};

struct node{
	int x;
	int y;
	node(){ };
	node (int sx,int sy){
		x=sx;
		y=sy;
	}
};

char mp[1001][1001];
bool vis[1001][1001];


queue<node> q;
queue<node> q1;


void bfs(int x,int y){
	q1.push(node(x,y));
	vis[x][y]=1;
	while(!q.empty()){
		node prg = q.front();
		q.pop();
		
		
		for(int i=0;i<8;i++){
			int tx = prg.x+dir[i][0];
			int ty = prg.y+dir[i][1]; 
		
		
			if(!vis[tx][ty]&&mp[tx][ty] == 'X'){
				q.push(node(tx,ty));
				q1.push(node(tx,ty));
				vis[tx][ty]=1;
			}
		}
	} 
}

int n,m,x,y;

void change(){
	for(int i=0;i<=n+1;i++){
		for(int j=0;j<=m+1;j++){
			if(mp[i][j]!='X'&&mp[i][j]!='.'){
					mp[i][j]='.';
			}
		}
	}
		q.push(node(x,y));
		bfs(x,y);
	while(!q1.empty()){
			node prg = q1.front();
			q1.pop();
		for(int i=0;i<4;i++){
				int tx=prg.x+dir[i][0];
				int ty=prg.y+dir[i][1];
			if(mp[tx][ty]=='.'){
					ans++;
			}
		}
	}
}

int main(){
	
	while(cin >> n >> m>> x>>y&&n&&m){
		
		ans=false;
		
		memset(vis,0,sizeof vis);
        memset(mp,'\0',sizeof mp);
		
		
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				cin >> mp[i][j];
			}
		} 
		change();
		cout<< ans << endl;
	}
	
	return 0;
}
相關文章
相關標籤/搜索