C++實現大數相加 hdu

c++實現大數相加,hdu1002解析

題目描述:ios

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include <iostream>

using namespace std;
string CalculateTwoBigNum(string a,string b){
    int i,j,k;
    int a_Length = a.length();
    int b_Length = b.length();
    string BigerNum = a; //默認兩個數字中更大爲a
    string SmallerNum = b;
    if(a_Length<=b_Length){
        BigerNum = b;
        SmallerNum = a;
    }
    string result = BigerNum;
    for(i=BigerNum.length()-1,j=SmallerNum.length()-1;j>=0;i--,j--){
        result[i] = BigerNum[i] + SmallerNum[j]-'0';
    }
    for(k=BigerNum.length()-1;k>=0;k--){
        if(result[k]>'9'){
            result[k] = result[k]-10;
            if(k-1>=0){
                result[k-1] =result[k-1]+1;
            }
            else
                result = "1" + result;
        }
    }
    return result;
}

int main()
{
    int Frequence; //計算次數
    string a,b; //參與計算的兩個數
    string result; //計算結果
    cin>>Frequence;
    int Flag = 1; // case Flag
    while (Frequence--) {
        cin>>a>>b;
        result = CalculateTwoBigNum(a,b);
        printf("Case %d:\n",Flag++);
        cout<<a<<" + "<<b<<" = "<<result<<endl;
        if (Frequence>=1){
            cout<<endl;
        }

    }
    return 0;
}
相關文章
相關標籤/搜索