Parity game---poj1733

Descriptionios

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Inputgit

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output數組

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Inputless

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Outputide

3


題意:有一個長度爲n的01串,有m句話,每句話說明x到y之間是有奇數(odd)個1仍是偶數(even)個1;求的是前幾句話是真的;若是所有爲真輸出m;

每輸入一句話時,能夠判斷是否和以前的話相沖突,用r[i]表示i到i的跟節點之間1的個數是偶數仍是奇數,1表示奇數,0表明偶數;

本題的n是10億,因此不能定義一個10億的數組;用map<int,int>定義就行


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<map>
#define N 105
#define INF 0xfffffff
using namespace std;

//int f[N], r[N];//r[i]表明i到i的跟節點之間的關係;
map<int,int> f;
map<int,int> r;

int Find(int x)
{
    if(!f[x])
        return x;
    int k = f[x];
    f[x] = Find(f[x]);
    r[x] = (r[x]+r[k])%2;
    return f[x];
}
int main()
{
    int px, py, flag, ans, i, n, m, x, y, d;
    char str[15];
    while(scanf("%d", &n)!=EOF)
    {
        flag = 0;
        f.clear();
        r.clear();
        scanf("%d", &m);
        for(i = 1; i <= m; i ++)
        {
            scanf("%d%d%s", &x, &y, str);
            x--;
            if(str[0] == 'e')//偶數是0;奇數是1;
                d = 0;
            else
                d = 1;
            px = Find(x);
            py = Find(y);
            if(px != py)
            {
                f[px] = py;
                r[px] = (r[y] + d - r[x] +2)%2;//畫向量圖找關係;
            }
            else if(flag==0 && (2 + r[x]-r[y])%2 != d)
            {
                flag = 1;
                ans = i;
            }
        }
        if(flag==0)//若是所有都正確的話輸出m;-_-在這wa了一次;
            ans=m+1;
        printf("%d\n", ans-1);
    }
    return 0;
}
View Code

 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<map>
#define N 105
#define INF 0xfffffff
using namespace std;

//int f[N], r[N];//r[i]表明i到i的跟節點之間的關係;
map<int,int> f;
map<int,int> r;

int Find(int x)
{
    if(!f[x])
        return x;
    int k = f[x];
    f[x] = Find(f[x]);
    r[x] = (r[x]+r[k])%2;
    return f[x];
}
int main()
{
    int px, py, flag, ans, i, n, m, x, y, d;
    char str[15];
    while(scanf("%d", &n)!=EOF)
    {
        flag = 0;
        f.clear();
        r.clear();
        scanf("%d", &m);
        for(i = 1; i <= m; i ++)
        {
            scanf("%d%d%s", &x, &y, str);
            x--;
            if(str[0] == 'e')//偶數是0;奇數是1;
                d = 0;
            else
                d = 1;
            px = Find(x);
            py = Find(y);
            if(px < py)
            {
                f[px] = py;
                r[px] = (r[y] + d - r[x]+2)%2;//畫向量圖找關係;
            }
            else if(px > py)
            {
                f[py] = px;
                r[py] = (r[x] - r[y] - d + 2)%2;
            }

            else if(px==py &&flag==0 && (r[y] - r[x] + 2)%2 != d)
            {
                flag = 1;
                ans = i;
            }
        }
        if(flag==0)//若是所有都正確的話輸出m;-_-在這wa了一次;
            ans=m+1;
        printf("%d\n", ans-1);
    }
    return 0;
}
View Code
相關文章
相關標籤/搜索