hdu 5277 YJC counts stars 暴力

YJC counts stars

Time Limit: 20 Secphp

Memory Limit: 256 MBnode

題目鏈接

http://acm.hdu.edu.cn/showproblem.php?pid=5277ios

Description

YJC是個老火車小司機。一個晚上,他仰望天空,星辰璀璨,他忽然以爲,天空就像一個平面,而每個星辰,就是平面中的一個點。
他把這些點編號爲1到n。這些點知足任意三點不共線。他把一些點用線段連起來了,可是任意兩條線段不會在端點之外相交。若是一個點的集合中任意兩個點都有一條線段直接相連,就稱爲dujiao點集。他想讓你求出最大的dujiao點集大小以及最大的dujiao點集個數。ide

Input測試

多組測試。
對於每組數據:
第一行兩個整數n,m,表示點數和線段數。
接下來n行每行兩個整數x,y,表示第i個點的座標。
接下來m行每行兩個整數u,v,表示一條鏈接u和v的線段。spa

Output排序

對於每組數據輸出兩個用空格隔開的整數表示最大的dujiao點集大小以及最大的dujiao點集個數。three

Sample Inputip

2 1
1 1
2 2
1 2
3 3
1 1
2 2
4 5
1 2
2 3
3 1ci

Sample Output

2 1
3 1

 

HINT

 

1≤n≤1000 −109≤x,y≤109 1≤T≤5(T是數據組數)
保證沒有相同的點和相同的邊,也沒有u=v的狀況

題意

 

題解:

首先針對你們提出的m的數據範圍的問題,其實對於平面圖來講有m≤3n−6……
首先五個點的團就是平面圖斷定中提到的K5,包含子圖K5就不是平面圖。因此答案只多是4。
那麼怎麼統計答案呢?
暴力枚舉第一個點,再枚舉第二個點,在枚舉第三個,第四個,要求每一個點都與前面其餘點聯通。你會發現這就過了,爲何呢?
枚舉第一個點是O(n)的,枚舉第二個點是O(n2),可是注意m=O(n),因而枚舉第三個點只有O(n)次,總次數也是O(n2)的。注意到平面圖三元環的個數是O(n)的,由於把一個點的相鄰點按照幾角排序,那麼這些點的連邊至關因而若干個區間,而區間不能相交,因此總共就是∑degi=O(m)(degi表示度數)的。因而枚舉第四個點的次數也是O(n)的,總複雜度就是O(n2)。對於n=1000來時徹底夠了。

代碼

#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
#include <stack>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define test freopen("test.txt","r",stdin)
#define maxn 1005
#define mod 10007
#define eps 1e-9
const int inf=0x3f3f3f3f;
const ll infll = 0x3f3f3f3f3f3f3f3fLL;
inline ll read()
{
    ll x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
//**************************************************************************************
struct node
{
    int x,y;
};
node a[maxn];
int g[maxn][maxn];
vector<int> G[maxn];
int one,two,three,four;
int n,m;
void init()
{
    one=two=three=four=0;
    memset(a,0,sizeof(a));
    memset(g,0,sizeof(g));
    for(int i=0;i<n;i++)
        G[i].clear();
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        for(int i=0;i<n;i++)
            a[i].x=read(),a[i].y=read();
        for(int i=1;i<=m;i++)
        {
            int x=read(),y=read();
            x--,y--;
            g[x][y]=g[y][x]=1;
            G[x].push_back(y);
            G[y].push_back(x);
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<G[i].size();j++)
            {
                for(int k=0;k<G[i].size();k++)
                {
                    if(G[i][j]!=G[i][k]&&g[G[i][j]][G[i][k]])
                    {
                        three++;
                        for(int t=0;t<G[i].size();t++)
                        {
                            if(G[i][j]!=G[i][k]&&G[i][j]!=G[i][t]&&G[i][k]!=G[i][t]&&g[G[i][j]][G[i][k]]&&g[G[i][j]][G[i][t]]&&g[G[i][k]][G[i][t]])
                            {
                                four++;
                            }
                        }
                    }
                }
            }
        }
        if(four)
            cout<<"4 "<<four/24<<endl;
        else if(three)
            cout<<"3 "<<three/6<<endl;
        else if(m)
            cout<<"2 "<<m<<endl;
        else
            cout<<"1 "<<n<<endl;
    }
}
相關文章
相關標籤/搜索