1、實驗目的:掌握PAP與CHAP認證配置oop
2、拓撲圖:測試
3、具體步驟配置:spa
(1)R1路由器配置:3d
Router>enable --進入特權模式router
Router#configure terminal --進入全局配置模式blog
Enter configuration commands, one per line. End with CNTL/Z.ip
Router(config)#hostname R1 --修改路由器名爲R1ci
R1(config)#interface l0 --進入迴環端口路由
R1(config-if)#ip address 192.168.1.254 255.255.255.0 --配置ip地址terminal
R1(config-if)#no shutdown --激活端口
R1(config-if)#exit --返回上一級
R1(config)#interface s0/0/0 --進入端口
R1(config-if)#ip address 192.168.12.1 255.255.255.0 --爲端口配置ip地址
R1(config-if)#clock rate 64000 --設置時鐘同步速率
R1(config-if)#no shutdown --激活端口
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit --返回上一級
R1(config)#route rip --開啓rip服務
R1(config-router)#version 2 --版本2
R1(config-router)#no auto-summary --關閉路由自動彙總
R1(config-router)#network 192.168.1.0 --添加直連網段到rip
R1(config-router)#network 192.168.12.0
R1(config-router)#exit --返回上一級
R1(config)#username abc1 password 456 --在中心路由器R1上爲遠程路由器R2設置用戶名和密碼
R1(config)#interface s0/0/0 --進入端口
R1(config-if)#encapsulation ppp --封裝端口爲ppp
R1(config-if)#ppp authentication pap --在R1上,配置PAP 驗證
R1(config-if)#ppp pap sent-username abc password 123 --在中心路由器R1上爲遠程路由器R2設置用戶名和密碼
R1(config-if)#end --返回特權模式
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1#
%SYS-5-CONFIG_I: Configured from console by console
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
(2)R2路由器配置:
Router>enable --進入特權模式
Router#configure terminal --進入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2 --修改路由器名爲R2
R2(config)#interface l0 --進入迴環端口
R2(config-if)#ip address 192.168.2.254 255.255.255.0 --配置ip地址
R2(config-if)#no shutdown --激活端口
R2(config-if)#exit --返回上一級
R2(config)#interface s0/0/0 --進入端口
R2(config-if)#ip address 192.168.12.2 255.255.255.0 --爲端口配置ip地址
R2(config-if)#no shutdown --激活端口
R2(config-if)#interface s0/0/1 --進入端口
R2(config-if)#ip address 192.168.24.2 255.255.255.0 --爲端口配置ip地址
R2(config-if)#clock rate 64000 --設置時鐘同步速率
R2(config-if)#no shutdown --激活端口
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
R2(config-if)#exit --返回上一級
R2(config)#route rip --開啓rip協議
R2(config-router)#version 2 --版本2
R2(config-router)#no auto-summary --關閉路由自動彙總
R2(config-router)#network 192.168.2.0 --添加直連網段到rip
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.24.0
R2(config-router)#exit --返回上一級
R2(config)#username abc password 123 --在R2上爲R1設置用戶名和密碼
R2(config)#username R3 password cisco --在R2上爲R3設置用戶名和密碼(注意兩端密碼要相同)
R2(config)#interface s0/0/0 --進入端口
R2(config-if)#encapsulation ppp --封裝端口爲PPP協議
R2(config-if)#ppp authentication pap --配置PAP驗證
R2(config-if)#ppp pap sent-username abc1 password 456 --在R2上爲R1設置用戶名和密碼
R2(config-if)#interface s0/0/1 --進入端口
R2(config-if)#encapsulation ppp --封裝端口爲ppp協議
R2(config-if)#ppp authentication chap --配置chap驗證
R2(config-if)#end --返回特權模式
R2#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%SYS-5-CONFIG_I: Configured from console by console
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
(3)R3路由器配置:
Router>enable --進特權模式
Router#configure terminal --進入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3 --修改路由器名爲R3
R3(config)#interface l0 --進入迴環端口
R3(config-if)#ip address 192.168.3.254 255.255.255.0 --爲端口配置ip地址
R3(config-if)#no shutdown --激活端口
R3(config-if)#exit --返回上一級
R3(config)#interface S0/0/0 --進入端口
R3(config-if)#ip address 192.168.24.1 255.255.255.0 --爲端口配置ip地址
R3(config-if)#no shutdown --激活端口
R3(config-if)#exit --返回上一級
R3(config)#route rip --開啓rip協議
R3(config-router)#version 2 --版本2
R3(config-router)#no auto-summary --關閉路由自動彙總
R3(config-router)#network 192.168.3.0 --添加直連網段到rip
R3(config-router)#network 192.168.24.0
R3(config-router)#exit --返回上一級
R3(config)#username R2 password cisco --在R3上爲R2設置用戶名和密碼
R3(config)#interface s0/0/0 --進入端口
R3(config-if)#encapsulation ppp --封裝端口爲ppp協議
R3(config-if)#ppp authentication chap --配置chap驗證
R3(config-if)#end --返回特權模式
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R3#
%SYS-5-CONFIG_I: Configured from console by console
4、驗證測試:
一、測試是否開啓ppp認證
(1)R1:
(2)R2:
(3)R3:
二、查看R1的S0/0/0端口信息
如圖,紅色標記處表示是PPP認證
三、測試全網是否互通:
(1)R1與R2
(2)R2與R3
(3)R3與R1
結果:全網互通成功!!!